const regex = /t/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('t', 'gm')
const str = `192.168.0.1
127.0.0.1
23.54.23.167
// 只匹配上面的 ip 地址
---分割线---
1000.1.1.1
192..168.0.1
192.168.0.1000
192.168.1.a
256.22.23.4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}