import Foundation
let pattern = #"\Dshared\Dsections\D\d{3,5}[?](program_id|nav_info=&program_id)=6"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Past Strings:
\Dshared\Dsections\D\d{3,5}[?]nav_info=&{0,1}program_id=6
Pass:
/shared/sections/6032?nav_info=&program_id=6
/shared/sections/6027?program_id=6
/shared/sections/8990?program_id=6
/shared/sections/6115?nav_info=&program_id=6
/shared/sections/7318?program_id=6
/shared/sections/8996?program_id=6
/shared/sections/6324?nav_info=&program_id=6
/shared/sections/6332?program_id=6
/shared/sections/6333?program_id=6
/shared/sections/6334?program_id=6
Fail:
/shared/programs/6/lessons/1126/slide_shows
/shared/programs/6/lessons/964/slide_shows
/shared/programs/6/lessons/944/slide_shows
/shared/programs/6/lessons/963/slide_shows
/shared/programs/6/lessons/970/slide_shows
/shared/sections/7352?nav_info=&program_id=15
/shared/sections/8991?program_id=15
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)