// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)CREATE INDEX (.*)|CREATE CLUSTERED INDEX (.*)|CREATE NONCLUSTERED INDEX (.*)").unwrap();
let string = "CREATE INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]
CREATE CLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]
CREATE NONCLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}