import re
regex = re.compile(r"First Name[\s\S](?<firstname>.*)[\s\S]Last Name[\s\S](?<lastname>.*)[\s\S]Phone[\s\S](?<phone>.*)[\s\S]E-Mail[\s\S](?<email>.*)[\s\S]*age group\?[\s\S](?<agegroup>.*)[\s\S]*seeing things up close[\s\S](?<farsightedness>.*)[\s\S]*cannot see very well[\s\S](?<astigmatism>.*)[\s\S]*-Glasses[\s\S](?<glasses>.*)[\s\S]*-Contacts[\s\S](?<contacts>.*)[\s\S]*-Reading Glasses[\s\S](?<readingglasses>.*)[\s\S]*following\?-(?<following>.*)[\s\S]*distance without relying on glasses and contact lenses.[\s\S](?<distance>.*)[\s\S]*close without relying on glasses and contact lenses.[\s\S](?<close>.*)[\s\S]*contacts\?[\s\S](?<wouldyourcareerimprove>.*)[\s\S]*Test Score[\s\S](?<testscore>.*)[\s\S]*Entry ID: (?<entryid>.*)[\s\S].*Referrer: (?<referrer>.*)[\s\S]*Host: (?<formhost>.*)", flags=re.MULTILINE)
test_str = ("First Name Melissa\n"
"Last Name Madrid\n"
"Phone 4253068210\n"
"E-Mail Meli.madrid@yahoo.com\n"
"What is your age group? 19-39\n"
"Without my glasses and contacts-Farsightedness : I have trouble reading and seeing things up close yes\n"
"Without my glasses and contacts-Astigmatism : I have distorted vision and cannot see very well yes\n"
"What do you usually wear?-Glasses yes\n"
"What do you usually wear?-Contacts yes\n"
"What do you usually wear?-Reading Glasses yes\n"
"Do you have any of the following?-None of the above yes\n"
"I would like to see well at a distance without relying on glasses and contact lenses. 5\n"
"I would like to see well up close without relying on glasses and contact lenses. 5\n"
"Would your career or business activities improve if you were to become less dependent on glasses and contacts? Yes\n"
"Test Score -4.00\n\n"
"The message has been sent from 107.77.205.32 (United States) at 2020-01-10 10:39:44 on iPhone unknown\n"
"Entry ID: 2190\n"
"Referrer: http://m.facebook.com\n"
"Form Host: https://www.nweyes.com/landing/smile/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")