$re = '/(\d|\d\d|[01]\d\d|2[0-4]\d|25[0-5])\./';
$str = '111.111.111.111';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);