package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^SERVICE NOTIFICATION:\s[^;]*(.*)`)
var str = `SERVICE NOTIFICATION: 9123456780;www.test.com;Kibana_Service_Check;CRITICAL;notify-service-by-email;connect to address xx.xx.xxx.xxx and port 5601: Connection refused`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}