package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w ]+).*? Your Age is: (\d+).*?email is: ([\w@].*?) Your`)
var str = `FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}