// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\w ]+).*? Your Age is: (\d+).*?email is: ([\w@].*?) Your").unwrap();
let string = "FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}