#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(!\[.*?]\()(?:https:\/\/example\.com\/*)?(.*?)(\))"
Local $sString = "Some text  " & @CRLF & _
"some text  some other text " & @CRLF & _
" "
Local $sSubst = "$1https://example.com/$2?raw=true$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)