// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)休憩\S*\s*(なし|無し)").unwrap();
let string = "休憩なし
休憩:なし
休憩時間: 無し
休憩 無し
休憩 なし";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}