using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^rgba?\((?:\s+)?(?<r>\d+(?<unit>%?))(?:\s+)?(?<separator>[\s|,])(?:\s+)?(?<g>\d+\k<unit>)(?:\s+)?\k<separator>(?:\s+)?(?<b>\d+\k<unit>)(?:\s+)?(?:(?<=(?:,.+))(?:,(?:\s+)?(?<a>(?:\d+)?(?:\.?\d+)))?(?:\s+)?)?\)$";
string input = @"// Valid
rgb(120 , 42 , 55)
rgb(23%, 100%, 0%)
rgb(120 42 55)
rgb(23% 100% 0%)
rgb(0 0 0)
rgba(23, 53, 0)
// Invalid
rgb(255, 120 0)
rgb(100% 32 75)
// When an alpha channel is defined, separator must be comma (not sure why but you can try it in browser to see for yourself)
// Valid
rgb(255, 255, 255, 1)
rgb(255, 255, 255, .643)
rgb(255, 255, 255, 1.324 )
rgba(255, 255, 255, 1)
rgba(255, 255, 255, .643)
rgba(255, 255, 255, 1.324 )
// Invalid
rgb(255, 255, 255, )
rgb(255, 255, 255, .)
rgba(255 255 255 1)
rgba(255 255 255, 1)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}