re = /(^|\s)#(\w+)\b/
str = '#test1.#test2 #test3 www.google.com/#test4 www.google.com/hello#test5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end