# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([T\$])([-+]?)(\d*)(\s?)(\d+)(\,)(\d+)$/$1$2$3$5.$7/gm;t' <<< "!Type:Bank
D2023-11-20
T-2 043,51
PCARTE 19/11/23 LEROY MERLIN
LBricolage et jardinage
^
"