package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([T\$])([-+]?)(\d*)(\s?)(\d+)(\,)(\d+)$`)
var str = `!Type:Bank
D2023-11-20
T-2 043,51
PCARTE 19/11/23 LEROY MERLIN
LBricolage et jardinage
^
`
var substitution = "$1$2$3$5.$7"
fmt.Println(re.ReplaceAllString(str, substitution))
}