import Foundation
let pattern = #"^([T\$])([-+]?)(\d*)(\s?)(\d+)(\,)(\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
!Type:Bank
D2023-11-20
T-2 043,51
PCARTE 19/11/23 LEROY MERLIN
LBricolage et jardinage
^
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$5.$7"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)