$re = '/1(?!.*[23456789])|2(?!.*[3456789])|3(?!.*[456789])|4(?!.*[56789])|5(?!.*[6789])|6(?!.*[789])|7(?!.*[89])|8(?!.*[9])|9(?!.*[9])/m';
$str = '26418917853216548456418745445321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);