import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[ \\/]*[a-z0-9])[a-z0-9\\/ ]{1,20}$";
final String string = "asdas//A9898AAA\n"
+ "abcde / asbas\n"
+ "avcdesc\n"
+ "AVASD/ASDB\n"
+ " ///aaa\n"
+ "aaaa / \n"
+ " //aa aa\n"
+ " /aaa aaa/// ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}