const regex = /(?<=\.)([^.]+)(?:\.(?:co\.uk|ac\.us|[^.]+(?:$|\n)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\.)([^.]+)(?:\\.(?:co\\.uk|ac\\.us|[^.]+(?:$|\\n)))', 'g')
const str = `m.google.com
m.docs.google.com
www.someisotericdomain.innersite.mall.co.uk
www.ouruniversity.department.mit.ac.us
www.somestrangeurl.shops.relevantdomain.net
www.example.info`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}