import Foundation
let pattern = #"(?<=\.)([^.]+)(?:\.(?:co\.uk|ac\.us|[^.]+(?:$|\n)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
m.google.com
m.docs.google.com
www.someisotericdomain.innersite.mall.co.uk
www.ouruniversity.department.mit.ac.us
www.somestrangeurl.shops.relevantdomain.net
www.example.info
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)