$re = '/^[A-Z][A-Z_0-9]*$(?<!_)/m';
$str = 'AAa
AA-
AA+
AA_
TT_A9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);