#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^if.*\R+(?:^[\t ]+.*\R+)*?^[\t ]+test\.check\(\).*\R?"
Local $sString = "if global_var:" & @CRLF & _
" fizz()" & @CRLF & _
" test.buzz()" & @CRLF & _
" test.check()" & @CRLF & _
" bang()" & @CRLF & _
" bop()" & @CRLF & _
"" & @CRLF & _
"would match but not any of the following" & @CRLF & _
"" & @CRLF & _
"fizz()" & @CRLF & _
"test.buzz()" & @CRLF & _
"test.check()" & @CRLF & _
"bang()" & @CRLF & _
"bop()" & @CRLF & _
"" & @CRLF & _
"if global_var:" & @CRLF & _
" fizz()" & @CRLF & _
" test.buzz()" & @CRLF & _
" bang()" & @CRLF & _
" bop()" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")