$re = '/a ([0-9]+)/';
$str = 'a 10 b 12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);