package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[[:alnum:]*.]+[^[:space:]]*[[:space:]]+@`)
var str = `*.info;mail.none;authpriv.none;cron.none /var/log/messages
authpriv.* /var/log/secure
mail.* -/var/log/maillog
cron.* /var/log/cron
*.emerg :omusrmsg:*
auth.*,authpriv.* @loghost.example.com:10514 # One "@" means UDP
*.* @@loghost.example.com # Two "@" means TCP`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}