import re
regex = re.compile(r"^[[:alnum:]*.]+[^[:space:]]*[[:space:]]+@", flags=re.MULTILINE)
test_str = ("*.info;mail.none;authpriv.none;cron.none /var/log/messages\n"
"authpriv.* /var/log/secure\n"
"mail.* -/var/log/maillog\n"
"cron.* /var/log/cron\n"
"*.emerg :omusrmsg:*\n"
"auth.*,authpriv.* @loghost.example.com:10514 # One \"@\" means UDP\n"
"*.* @@loghost.example.com # Two \"@\" means TCP")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")