package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)berry|^apple$|watermelon`)
var str = `strawberry
orange
blueberry
apple
pineapple
watermelon
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}