re = /berry|^apple$|watermelon/m
str = 'strawberry
orange
blueberry
apple
pineapple
watermelon
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end