import Foundation
let pattern = #"(\d+-\d+-\d+\s\d+:\d+:\d+,\d+)\s(\S+\s-\s\S+)\s(\w+)\s(.*)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2019-10-20 17:01:17,252 [//127.0.0.1/ - /envcenter/shippinglist/query_shippinglist_settings.json?productId=ap_philippines] ERROR impl.GitRepositoryInfoRemoteImpl - 请求gitlab api失败
java.io.FileNotFoundException: http://gitlab.alipay-inc.com/api/v3/projects/intl-sre-bm%2Fdevopaas-agent-id
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)