#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^"\s*([^"]+?)\s*"\s*:\s*"?([^"]+)"?$"
Local $sString = ""Name" : " hello"" & @CRLF & _
""Name":[]--->Name=[] ( []--->[ ] )" & @CRLF & _
""Name":123---->Name=123"
Local $sSubst = "\1= "\2""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)