using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""\s*([^""]+?)\s*""\s*:\s*""?([^""]+)""?$";
string substitution = @"\1= ""\2""";
string input = @"""Name"" : "" hello""
""Name"":[]--->Name=[] ( []--->[ ] )
""Name"":123---->Name=123";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}