use strict;
my $str = '"Name" : " hello"
"Name":[]--->Name=[] ( []--->[ ] )
"Name":123---->Name=123';
my $regex = qr/^"\s*([^"]+?)\s*"\s*:\s*"?([^"]+)"?$/mp;
my $subst = '\\1= "\\2"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";