#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=\<span class=\"highlight highlight--wrapping\"\>)(.*?)(?=\<\/span\>)"
Local $sString = "<div>... <span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span> (David Cantwell for Forbes) " & @CRLF & _
"" & @CRLF & _
"On a cool summer afternoon at Dublin's Heuston Station, <span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class="highlight highlight--wrapping">Feeney</span> likes it." & @CRLF & _
"<span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span> is the James ...</div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")