#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b((?![aeiou]{2}).)*[aeiou]\b"
Local $sString = "hielo hola agua hiellh aguas" & @CRLF & _
"hielo" & @CRLF & _
"hola" & @CRLF & _
"agua" & @CRLF & _
"hiellh" & @CRLF & _
"aguas"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")