import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(*)([\\w][\\w\\d.]*)\\s*([<>!=]{1,2}|like|not like|is null|is not null|in\\s*\\()?\\s*(?!and|or)(?:(?:(between )(['\"]?)(.*?)(\\5)( and )(['\"]?)(.*?)(\\9))|(?:(['\"]?)(.*?)(\\12)))\\s*(\\)*)\\s+(?!'|\")\\s*(and|or)?\\s*";
final String string = "id between 3 and 10 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}