const regex = /<Notes>(?:(?!<\/?Notes>|sample)[\s\S])*sample[\s\S]*?<\/Notes>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Notes>(?:(?!<\\\/?Notes>|sample)[\\s\\S])*sample[\\s\\S]*?<\\\/Notes>', 'gm')
const str = `TextBefore<Notes>this is sample notes</Notes>TextWithsample<Notes>this is sample notes</Notes>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}