re = /http:\/\/\S*\/([^\/]+)\.pdf/
str = 'http://mysite/strategy/annual-plan-16-17.pdf'
subst = '$0?pdf=$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result