import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9]+.*(?:\\d+-\\d+|\\*)$";
final String string = "sensor1-2\n"
+ "s1-2\n"
+ "s*\n"
+ "s_s*\n\n"
+ "sensor1\n"
+ "s1-\n"
+ "*s1-3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}