// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^proc _*(.*?)_*\*").unwrap();
let string = "proc foo*() =
discard
proc foo_*() =
discard
proc foo__*() =
discard
proc __foo*() =
discard
proc __foo__*() =
discard
proc foo_bar_*() =
discard
proc foo_bar*() =
discard
proc _foo_bar_*() =
discard";
let substitution = "proc $1*";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}