#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+[-|/]\d+[-|/]\d+\s\S+)\s+(\w+)\s+([^:]+):\s+(.+)*"
Local $sString = "2023-02-23 19:27:02 WARN SparkDriver(183): 是否使用testGo模式?false testGo模式下忽略命令行-b参数." & @CRLF & _
"2023-02-23 19:27:02 WARN SparkDriver(359): 命令行参数(cmdOption):{a=de_boardHistory, b=boardHistory, g=[loadToAdb=false, upsert=true, etlDate=20230222], w=null}" & @CRLF & _
"2023-02-23 19:27:02 INFO ConfigOption(111): 加载本地配置文件(local.config),覆盖项目配置" & @CRLF & _
"2023-02-23 19:27:02 INFO ConfigOption(78): 提取命令行(cmdOption)相同key,覆盖项目配置" & @CRLF & _
"2023-02-23 19:27:02 WARN SparkDriver(183): 项目配置(configOption)重要参数:{cluster=true, test=false, projectName=ATLAS-ETL..." & @CRLF & _
"23/02/23 20:03:25 WARN [Driver] SparkUtil: /---------------------------------------*" & @CRLF & _
"23/02/23 20:03:25 WARN [Driver] SparkUtil: * SparkDiver *" & @CRLF & _
"23/02/23 20:03:25 WARN [Driver] SparkUtil: * <spark-2.4.7, scala-2.11> *" & @CRLF & _
"23/02/23 20:03:25 WARN [Driver] SparkUtil: *---------------------------------------*/" & @CRLF & _
"23/02/23 20:03:25 INFO [Driver] SparkUtil: init spark..." & @CRLF & _
"23/02/23 20:03:25 INFO [Driver] SparkUtil: localTest: false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")