# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+[-|/]\d+[-|/]\d+\s\S+)\s+(\w+)\s+([^:]+):\s+(.+)*"
test_str = ("2023-02-23 19:27:02 WARN  SparkDriver(183): 是否使用testGo模式?false	 testGo模式下忽略命令行-b参数.\n"
	"2023-02-23 19:27:02 WARN  SparkDriver(359): 命令行参数(cmdOption):{a=de_boardHistory, b=boardHistory, g=[loadToAdb=false, upsert=true, etlDate=20230222], w=null}\n"
	"2023-02-23 19:27:02 INFO  ConfigOption(111): 加载本地配置文件(local.config),覆盖项目配置\n"
	"2023-02-23 19:27:02 INFO  ConfigOption(78): 提取命令行(cmdOption)相同key,覆盖项目配置\n"
	"2023-02-23 19:27:02 WARN  SparkDriver(183): 项目配置(configOption)重要参数:{cluster=true, test=false, projectName=ATLAS-ETL...\n"
	"23/02/23 20:03:25 WARN [Driver] SparkUtil: /---------------------------------------*\n"
	"23/02/23 20:03:25 WARN [Driver] SparkUtil: *               SparkDiver              *\n"
	"23/02/23 20:03:25 WARN [Driver] SparkUtil: *       <spark-2.4.7, scala-2.11>       *\n"
	"23/02/23 20:03:25 WARN [Driver] SparkUtil: *---------------------------------------*/\n"
	"23/02/23 20:03:25 INFO [Driver] SparkUtil: init spark...\n"
	"23/02/23 20:03:25 INFO [Driver] SparkUtil: localTest: false")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.