re = /(\d+[-|\/]\d+[-|\/]\d+\s\S+)\s+(\w+)\s+([^:]+):\s+(.+)*/m
str = '2023-02-23 19:27:02 WARN SparkDriver(183): 是否使用testGo模式?false testGo模式下忽略命令行-b参数.
2023-02-23 19:27:02 WARN SparkDriver(359): 命令行参数(cmdOption):{a=de_boardHistory, b=boardHistory, g=[loadToAdb=false, upsert=true, etlDate=20230222], w=null}
2023-02-23 19:27:02 INFO ConfigOption(111): 加载本地配置文件(local.config),覆盖项目配置
2023-02-23 19:27:02 INFO ConfigOption(78): 提取命令行(cmdOption)相同key,覆盖项目配置
2023-02-23 19:27:02 WARN SparkDriver(183): 项目配置(configOption)重要参数:{cluster=true, test=false, projectName=ATLAS-ETL...
23/02/23 20:03:25 WARN [Driver] SparkUtil: /---------------------------------------*
23/02/23 20:03:25 WARN [Driver] SparkUtil: * SparkDiver *
23/02/23 20:03:25 WARN [Driver] SparkUtil: * <spark-2.4.7, scala-2.11> *
23/02/23 20:03:25 WARN [Driver] SparkUtil: *---------------------------------------*/
23/02/23 20:03:25 INFO [Driver] SparkUtil: init spark...
23/02/23 20:03:25 INFO [Driver] SparkUtil: localTest: false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end