#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<==).*?(?=#{2}|$)"
Local $sString = " Identifier1 = Value1 ## Comment" & @CRLF & _
" Something = SomeData" & @CRLF & _
" Name = information\\t\\t\\t## More comments!" & @CRLF & _
" Nam2 = information"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")