#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?::\w*:|(?:\ud83c[\udf00-\udfff])|(?:\ud83d[\udc00-\ude4f\ude80-\udeff])|[\u2600-\u2B55])\s(?<type>[a-zA-Z-,\/]+)(?:\((?<scope>.*)\))?!?:\s(?<subject>(?:(?!#).)*(?:(?!\s).))(?:\s\(?(?<ticket>#\d*)\)?)?$"
Local $sString = "// Not Matched" & @CRLF & _
"chore(scope): test" & @CRLF & _
"" & @CRLF & _
"hello :test: test" & @CRLF & _
"" & @CRLF & _
":start:test: test" & @CRLF & _
"" & @CRLF & _
"// Matched" & @CRLF & _
"" & @CRLF & _
":hello: test: test" & @CRLF & _
"" & @CRLF & _
":start: chore(scope): test" & @CRLF & _
"" & @CRLF & _
":start: chore(scope): test #123" & @CRLF & _
"" & @CRLF & _
":memo: docs: update README.md" & @CRLF & _
"" & @CRLF & _
":start: chore(scope): i have a word #123" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
":package: feat(parser-opts): extract parser-opts packages" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
":sparkles: feat(changelog): 添加中文标题" & @CRLF & _
"" & @CRLF & _
":sparkles: feat(changelog): add chinese title" & @CRLF & _
"" & @CRLF & _
"✨ feat(unicode): add unicode support" & @CRLF & _
"" & @CRLF & _
"😌 test(only): add unicode support" & @CRLF & _
"" & @CRLF & _
":sparkles: feat: hello world (#100)" & @CRLF & _
"" & @CRLF & _
":green_heart: fix-ci(ci/cd): added release rules for all cz-emojis" & @CRLF & _
"" & @CRLF & _
":green_heart: ci/cd(config): changed config for cz-emojis" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")