using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?::\w*:|(?:\ud83c[\udf00-\udfff])|(?:\ud83d[\udc00-\ude4f\ude80-\udeff])|[\u2600-\u2B55])\s(?<type>[a-zA-Z-,\/]+)(?:\((?<scope>.*)\))?!?:\s(?<subject>(?:(?!#).)*(?:(?!\s).))(?:\s\(?(?<ticket>#\d*)\)?)?$";
string input = @"// Not Matched
chore(scope): test
hello :test: test
:start:test: test
// Matched
:hello: test: test
:start: chore(scope): test
:start: chore(scope): test #123
:memo: docs: update README.md
:start: chore(scope): i have a word #123
:package: feat(parser-opts): extract parser-opts packages
:sparkles: feat(changelog): 添加中文标题
:sparkles: feat(changelog): add chinese title
✨ feat(unicode): add unicode support
😌 test(only): add unicode support
:sparkles: feat: hello world (#100)
:green_heart: fix-ci(ci/cd): added release rules for all cz-emojis
:green_heart: ci/cd(config): changed config for cz-emojis
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}