#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)1[10]{16,}(?!\d)"
Local $sString = "------ Regla -------" & @CRLF & _
"12345678901234567890" & @CRLF & _
"----------------*---" & @CRLF & _
"11111111111111000" & @CRLF & _
"1111111111" & @CRLF & _
"10101010" & @CRLF & _
"11111111111111111" & @CRLF & _
"111111111111111111111" & @CRLF & _
"1010101010101010101010" & @CRLF & _
"10101010101010100" & @CRLF & _
"" & @CRLF & _
"Otros nĂºmeros no en base 2:" & @CRLF & _
"123456789011121314151617181920" & @CRLF & _
"1234" & @CRLF & _
"12310000000000000000321" & @CRLF & _
"12310000000000000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")