import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)1[10]{16,}(?!\\d)";
final String string = "------ Regla -------\n"
+ "12345678901234567890\n"
+ "----------------*---\n"
+ "11111111111111000\n"
+ "1111111111\n"
+ "10101010\n"
+ "11111111111111111\n"
+ "111111111111111111111\n"
+ "1010101010101010101010\n"
+ "10101010101010100\n\n"
+ "Otros números no en base 2:\n"
+ "123456789011121314151617181920\n"
+ "1234\n"
+ "12310000000000000000321\n"
+ "12310000000000000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}