$re = '/(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)/m';
$str = 'static public void main(String[] args)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);