package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{4}\-(?:1[0-2]|0?[1-9])\-(?:[12]\d|3[01]|0?[1-9])`)
var str = `2020-05-01
2020-5-3
2020-6-30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}