#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(\d+\.?|\.\d+)\d?(e-?\d+)?$"
Local $sString = "0" & @CRLF & _
"true" & @CRLF & _
"" & @CRLF & _
"0.1" & @CRLF & _
"true" & @CRLF & _
"" & @CRLF & _
"abc" & @CRLF & _
"false" & @CRLF & _
"" & @CRLF & _
"1 a" & @CRLF & _
"false" & @CRLF & _
"" & @CRLF & _
"2e10" & @CRLF & _
"true" & @CRLF & _
"" & @CRLF & _
"-90e3" & @CRLF & _
"true" & @CRLF & _
"" & @CRLF & _
"1e" & @CRLF & _
"false" & @CRLF & _
"" & @CRLF & _
"e3" & @CRLF & _
"false" & @CRLF & _
"" & @CRLF & _
"6e-1" & @CRLF & _
"true" & @CRLF & _
"" & @CRLF & _
"99e2.5" & @CRLF & _
"false" & @CRLF & _
"" & @CRLF & _
"53.5e93" & @CRLF & _
"true" & @CRLF & _
"" & @CRLF & _
"--6" & @CRLF & _
"false" & @CRLF & _
"" & @CRLF & _
"-+3" & @CRLF & _
"false" & @CRLF & _
"" & @CRLF & _
"95a54e53" & @CRLF & _
"false" & @CRLF & _
"" & @CRLF & _
"." & @CRLF & _
"false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")