import Foundation
let pattern = #"Expr"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
este es un ejemplo•de Expr donde podemos ver claramente
que, ésta•seleccion Expr, pero no me selecciona expr
¿por •que•me selecciona "Expr" pero no•me•selecciona• "expr" ?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<<reemplazar>>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)