Group protocol(?<protocol>edgedb:\/\/) edgedb:the literal text edgedb: (case sensitive) \/the literal / (4710 / 578 / 2F16)
\/the literal / (4710 / 578 / 2F16)
Group user(?<user>(?:\w|\d)+) Non-Capturing Group(?:\w|\d)+ +repeats the group contents below at least once:
:the literal : (5810 / 728 / 3A16)
Group pwd(?<pwd>(?:\w|\d)+) Non-Capturing Group(?:\w|\d)+ +repeats the group contents below at least once:
@the literal @ (6410 / 1008 / 4016)
Group host(?<host>(?:\w|\d)+) Non-Capturing Group(?:\w|\d)+ +repeats the group contents below at least once:
:the literal : (5810 / 728 / 3A16)
Group port(?<port>(?:\d)+) Non-Capturing Group(?:\d)+ +repeats the group contents below at least once:
\da digit
\/?optionally matches the literal / (4710 / 578 / 2F16)
Group db(?<db>(?:\w|\d)+)? ?repeats the group contents below at most once:
Non-Capturing Group(?:\w|\d)+ +repeats the group contents below at least once:
Group params(?<params>\/?.*) \/?optionally matches the literal / (4710 / 578 / 2F16)
.*any character (except for line terminators), repeated any number of times
$end of line
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string